Back to overview
Telephony is down
May 12, 2026 at 7:51pm UTC
Affected services
Telephony
Resolved
May 12, 2026 at 7:51pm UTC
We are investigating issues with our internal telephony systems
Affected services
Resolved
May 12, 2026 at 7:51pm UTC
We are investigating issues with our internal telephony systems
Affected services